Updating openssl

I would recommend that you wait another day and try again but also make sure you can access a browser first. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -march=pentium -Wa,--noexecstack -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM -DVPAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -c -o md2test.o md2test.c md2test.c:: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before â.â token make[1]: *** [md2test.o] Error 1 make[1]: Leaving directory `/home/stin/openssl-1.0.1h/test' make: *** [build_tests] Error 1 ***************************************************** Hey, nice post!

but the thing that got me confused a little bit was moving the files to /usr/local what I did was that I copied the line as it is and executed it without problems..

You just need to mention that directory in config command as --openssldir=~/openssl Please note that I haven't tested it but you can test in lab/dev first.Then restart the NGINX software to use the updated library.Check your vendor’s response to to determine the correct upgrade process.Run the , although the output might not be reliable if there are several instances of Open SSL on your server.We strongly recommend that you upgrade to the most recent Open SSL library provided by your operating system vendor, even if the earlier version you are running is not reported to be affected.

Search for updating openssl:

updating openssl-39updating openssl-88

Leave a Reply

Your email address will not be published. Required fields are marked *

One thought on “updating openssl”